Resource Balancer Script

saint311

Non-stop Poster
Anyone have any info on why this has stopped working on the beta world? I know it is beta, and may have the ability to shut down scripts (??). Call me spoiled but not having resource balancer is ruining tw for me...
 
Hi there


Firstly I'd like to thank you guys from the bottom of my heart for the excellent script I enjoy using so much, it made so much difference to my TW experience it's simply incredible.


Problem is it stopped working last night after what I think was a quick patch install by TW (I briefly got kicked out from the game but didn't think much of it until I discovered this morning that script doesn't work anymore)


I'm devastated and can't even imagine how I can cope without it now :icon_cry:
Is there any chance you could check it please?


As you probably noticed I only registered here today so I could contact you lol
PLEASE HELP :icon_redface:


Thanks mate
 

meepmeep.

Guest
Seems like you're having the same issue as the people here.

The reason for the issues is the new update. Here's Morthy's explanation. I doubt it will help you to fix your problem as you seem, like the rest of us, to rely on scripters to give us tools, but it should at least explain a bit.

Originally Posted by Morthy

In this update we changed all the places where you see the edit icon to easily rename something to all use the same standard system in an accessible way. Prior to this, each location was implemented differently and had a lot of problems. For example, if your session had expired or your internet connection / server had problems the renaming would just silently failing without telling you. While this will likely have broken some existing scripts, in the future it will be much easier for scripts to hook into renaming things because everything is done in the same way, so it shouldn't take long for script authors to update their scripts.

As a reminder, we do bring updates onto our Beta server before normal worlds, and even have a Sandbox world there to which scripters can apply to join and be granted some free villages and so on for testing. It is the responsibility of script authors to keep their scripts compatible with the game.
 

ronpaul2008

Guest
Wow. I can't believe my script is even still working. I haven't touched it in over 3 years.

I see some people hacked in some fixes. If someone wants to PM me what I need to fix in the master script, I'll do the work.

@theDominion - your PM caused me to get an email because my inbox was full. :)
 
Last edited by a moderator:
Thank you for the prompt reply
Unfortunately I have no idea what needs to be fixed :icon_sad:
All I know it was working like a charm up until 12-14 hrs ago and now it doesn't :icon_cry:
The one I'm using is hosted on your website
 

mankini

Guest
Wow. I can't believe my script is even still working. I haven't touched it in over 3 years.
A tribute to how well written the script was to start. I would just like to add my hope that you will be able to apply a correction to the script soon. Thanks again for this great tool you created. It is deeply missed, now that it is gone.
 

ronpaul2008

Guest
The script should be fixed. You will likely have to clear your browser cache to get the new one.
 
Last edited by a moderator:

Maintos

Guest
The script should be fixed. You will likely have to clear your browser cache to get the new one.
Thank you so very much! You make my gaming experience so much better. Indeed, all I had to do was clear my browser cache and the new script started working. I don't know how you do it but thank goodness for you :icon_smile:
 
The script should be fixed. You will likely have to clear your browser cache to get the new one.
God bless you! Can't tell you how much of a relief that is, can't stop to admire you guys, the whole community depends on your knowledge, we simply couldn't survive without you.
Just one tiny thing if I may - is there any chance it could open links on the background as before? If not, it's not a biggy really :icon_smile:
 

mankini

Guest
The script should be fixed. You will likely have to clear your browser cache to get the new one.
Thank you a million times over. This is one of the most useful scripts in the game. It is also one of the more sophisticated ones particularly in that it works so smoothly.

@dominion - right click the pop links hyperlink... choose, "open tabs in background"
 

anarkiss

Guest
First off thank you sooo much for this beautiful script. I just tried it after it was fixed and it still isn't working for me. I am clicking the bookmark with the script in my production page and the new window pops up with my production page. I hit it again and the new window turns into the options page for the scrtip. (so far so good.) I hit submit to show me the pop up links and then click on 1 villages link. Here is where the problem is. When I click the script button to insert the res amounts it does nothing. Doesn't hit ok or put the numbers in to make the trade. I have cleared my cache and reset all settings. I am using chrome. Any help would be great!
 

dylar

Guest
Hmm. Well Cache cleaned. pop ups check, got the script from your site check, click script and absolutely nothing happens.
Any other ideas on what could be the issue here?

Thanks for all of your effort!
 

Black.Plague

Contributing Poster
Cache cleaned, checked Pop-ups. Script goes till the http://www.extremetw.com site and gives the links.
I open the link tabs and then it doesnt work anymore. It doesnt fill the resorces nor does send any.

Pissing off couse for the same script others in tribe saying it works
:icon_confused:
 

Maintos

Guest
Mine stopped working earlier today, anyone else having this issue?
Yes, after using script an alert window pops up saying, "Please wait for the page to fully load" I've tried to use it repeatedly but get the same results. I wonder if the coding was changed again within the game and messed with the script.