misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
Author
RedAlert
Contributors
N/A
Quickbar Entry
javascript:$.getScript('https://twscripts.dev/scripts/singleVillageSnipe.js');
Public?
Public
Single Village Snipe

single-village-snipe.png

Script needs to be run on this screen:
/game.php?screen=info_village&id=XXXX

Demo Video:

If you have an incoming and/or your own command landing on the current opened village, click on the command/incoming and landing time field will be updated to match the landing time of the command/incoming.

If you have any issues with the script, found a bug, or have some suggestion feel free to reply on this thread.
 
Changelog
-> v1.8.0 (2022-05-10) https://forum.tribalwars.net/index.php?threads/single-village-snipe.286731/post-7151444
-> v1.7.0 (2022-02-03) https://forum.tribalwars.net/index.php?threads/single-village-snipe.286731/post-7146917
-> v1.6.0 (2021-12-30): https://forum.tribalwars.net/index.php?threads/single-village-snipe.286731/post-7145234
-> v1.4.0 (2021-08-25): https://forum.tribalwars.net/index.php?threads/single-village-snipe.286731/post-7142703

===> 05/04/2021 (v.1.2.0)
Added export and import configurations capability

===> 23/03/2021 (v1.1.4)
Converted group filtering from buttons to select dropdown.
Added a new field "Min. Amount" (with a default value of 50, units).

===> 28/02/2021 (v1.1.0)
Added support for sigil snipe
Added destination village field allowing the player to enter custom village coordinates
Last edited:
Upvote 2

misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
Script updated to v1.4.0

1630096607058.png

On this new script version I added a way for the player to clear the chosen group.

The script saves in browser memory the last group the player had chosen. However, it happened that players deleted those groups and that created an issue with the script since it could not fetch data when it initially loaded.

The new button "Reset Chosen Group" solves this problem by clearing the script memory.
 

misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
Script updated to v1.6.0

Changelog:

- improved way how changing groups worked (when you change groups you can keep working no need to reload the page and restart script it works automatically)
- added more debug options on the script since I noticed people had issues (especially when it came to groups)

There where no UI changes made on this script update.
 

misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
Script has been updated to v1.7.0

1643901973283.png


There is no UI change that was done on this script update.

Changelog:
- When "Calculate Launch Times" is clicked the chosen units are saved in localStorage. So when you run the script again you will have selected the units you last chose.

Small QoL improvement.

Feel free to suggest ideas on how to make the script better.
 

misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
Script is updated to v1.8.0

IMG_20220510_175928.jpg

Added support for the mobile app.

If you have any issues with the script, found a bug, or have some suggestion feel free to reply on this thread.

Credits to @IIIII III since he suggested working on this and prepared some code samples that I utilized.
 
Last edited:

.MAXIMUS.

Well-Known Member
Reaction score
18
You have done an awesome job again and we all appreciate it.

There is just one small bug on the mobile version. When choosing Paladin or Noble, it finds nothing.
The exact same inputs (coords, groups or all) works perfectly on the desktop version but not on the mobile one.

Later edit:
Since Sunday it doesn't work at all on mobile, just on the desktop.
 
Last edited:

.MAXIMUS.

Well-Known Member
Reaction score
18
*Bump.

Ever since that mobile app support was added, the script is still broken for tablets and smartphone browsers, both in the mobile and also browser version. :(
 

TuRBo-x

Active Member
Reaction score
13
I found a problem " when I click on the train needs sniping the time for sniping becomes 1 sec earlier"
Can you fix that.
 

misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
I found a problem " when I click on the train needs sniping the time for sniping becomes 1 sec earlier"
Can you fix that.
Thank you for reporting this issue.

This is an known issue that I have personally replicated while using the script multiple times.

I will have to investigate if its fixable though and if it is fixable, it will be fixed on a future script update.

Thank you again for reporting this issue.
 

Warkriget

New Member
Reaction score
0
I think this script stopped working, worked fine 1 week ago :/ When selecting a time I want to snipe, it gives me a message "no possible snipe options found", when there are villages close enough to snipe.
EDIT: NEVER MIND xd, I disabled some things in game settings that might have created some bug, enabling the game settings made the script work again :)
 
Last edited:

sirron

New Member
Reaction score
0
I think this script stopped working, worked fine 1 week ago :/ When selecting a time I want to snipe, it gives me a message "no possible snipe options found", when there are villages close enough to snipe.
EDIT: NEVER MIND xd, I disabled some things in game settings that might have created some bug, enabling the game settings made the script work again :)
What game settings did you change? Click the time inputs the incorrect time for me.
 

misteralb

In-Game Staff
Tribal Wars Team
Team
Script Moderator
Reaction score
443
I think this script stopped working, worked fine 1 week ago :/ When selecting a time I want to snipe, it gives me a message "no possible snipe options found", when there are villages close enough to snipe.
EDIT: NEVER MIND xd, I disabled some things in game settings that might have created some bug, enabling the game settings made the script work again :)
Hello,

Sorry for the very late answer :(

Your reply got lost from the other stuff I have been checking.

I have not changed anything on the script recently so I suspect whatever might have gone wrong could be related with bad data saved on the browser.

I would recommend trying with another browser and see if the script works fine there, or you could also try with the same browser, but on incognito mode.

If the script works fine there, then it means you need to reset the script configuration.

Added a new button on the script:

1668803456258.png

Reset Script, when you click that it should delete all the data that the script has saved in localStorage.

In theory, it should eliminate all possible issues.

Let me know if this solves the issue you have or not.
 
Top