Not A Bug Context Menu on Map screen is not opening

misteralb

Non-stop Poster
Tribal Wars Team
Script Moderator
Reaction score
212
Bug Priority
Medium Bug (gameplay slightly affected)
Bug Type
Functional bug
Bug Occurrence URL
https://us52.tribalwars.us/game.php?screen=map
Bug Reproduction Steps
0) Open Firefox and login in game using Firefox
1) Go to Settings -> Game Options
2) Make sure to have the field " Activate context menu: Show a context menu with multiple options when clicking on a village" checked.
3) Go to the map and try opening the context menu.
Bug Reproducibility
Happens always
I encountered what I think to be a cross-browser compatibility bug or possibly a JS error on the map library.

1619380079622.png

Whenever you click a village on the map this shows up when this setting is checked:

1619380121585.png

This works all okay, unless you do this on Firefox it seems.

On Firefox, the context menu does not show, no matter if the setting "Activate content menu" is checked or not.
 

misteralb

Non-stop Poster
Tribal Wars Team
Script Moderator
Reaction score
212
Thanks for checking this @DaWolf85 .

I experienced this issue for a while on Firefox. I did not had PA account there initially. So I thought the issue I was experiencing could be related with that.

I activated PA and was expecting the context menu to work ... it did not work (even though the context menu is not PA only feature and it only depends on the settings which I mentioned above).

Kept clicking on a map village and it only redirected to village info view.

Then, I closed browser, re-logged in game (this was after some time) and then it worked. Context menu worked :) which was weird.
 
Last edited:

JawJaw

Awesomest CM Ever
Tribal Wars Team
Community Management
Reaction score
1,418
I'm unable to reproduce this issue so I'll class this as not a bug. It might have been a small browser hiccup. Let us know if it happens again :)
 

SwedishBlueCheese

Well-Known Member
Reaction score
25
had this problem last few days on chrome. Comes after pressing several vills aftereachother. The claim button is usually still there.

Sometimes it shows only this aswell